Oil Pressure Readings not right.

Moderators: jlucas, RTUSA, kieran

Law
Posts: 2
Joined: Mon Aug 08, 2016 11:25 am

Oil Pressure Readings not right.

Postby Law » Mon May 15, 2017 3:25 pm

Good Afternoon,

I've meant to of posted here but not got round to it.

I used to run a MTX-D
(http://www.innovatemotorsports.com/prod ... D.php#3852)

Which gave me a pretty much solid 60psi once warm at high RPM to which I would expect. (This also matched the OEM gauge in the car)

Since moving over to the Dash2. It's down to around 40-45.

I use the Oil pressure sensor Race Tech sell. with the settings for that sensor in the Dash2 config.

Nothing has changed engine wise at all. I am going to be fitting a Mechanical gauge to confirm the readings when I get a chance.

But is there anything I can check with the Dash2?

Voltage to sensor?
Wiring?
voltage to Dash2?

Only reason I know it's misreading is there is no way I have 10psi at idle with a oil pump that has been shimmed.

Any advise or guidance will be great.


Also would it be good practice to wire up a relay for the Dash2 to run direct off the battery? As currently it's using the ECU CAN output. Sometimes I get ERROR on the MTX-L wideband during cranking as the wideband is also running off the ECU wideband feed which is shared with the CAN output. The ECU is showing 14.2-14.4v during use.

Thanks :D

Support (D)
Posts: 78
Joined: Mon Aug 17, 2015 9:36 am

Re: Oil Pressure Readings not right.

Postby Support (D) » Mon May 15, 2017 4:02 pm

Good afternoon,

Please send me your DASH2 configuration file, I will inspect it and send you an updated version if I find anything that can cause the issue you are seeing.

My email address is: daniel@race-technology.com

Best regards,
Support(D)

Law
Posts: 2
Joined: Mon Aug 08, 2016 11:25 am

Re: Oil Pressure Readings not right.

Postby Law » Mon May 15, 2017 4:10 pm

Support (D) wrote:Good afternoon,

Please send me your DASH2 configuration file, I will inspect it and send you an updated version if I find anything that can cause the issue you are seeing.

My email address is: daniel@race-technology.com

Best regards,
Support(D)



Thanks,

Daniel,

I will fire this over when I'm home! :)


Return to “Sensor-related questions”

Who is online

Users browsing this forum: No registered users and 1 guest