live-chat-status

Software Download

Version 10 software download contains all of the latest versions of all our programs in a single installation package.

V10 does not support legacy products such as DL1 MK2 and the VIDEO4. V8.5 is still available for supporting legacy products.

If you are looking for our GoPro Only Software (no Race Technology hardware required) that is available for download here.

Minimum requirements: Windows 7 or Windows 10, 64 bit. At least 8GB RAM with a solid-state drive is strongly recommended. Most applications are single threaded, the main exception being video handling which uses all CPU cores and the GPU if available.

MAC: We don't test on Macs, but we've got many users running under Parallels without any issues. Note that we do not officially support Macs and we don't have any Macs in the office to test with. However, if you do find an issue when running on Mac then let us know and we will see if there is anything we can do.

Security Software: This often causes problems, please be aware that our software is compiled on a secure machine, all the files are checked for viruses, all files are digitally signed and then built into an installable package that itself is digitally signed. Our software absolutely does not contain any viruses, trojans, malware, advertising or anything similarly unpleasant. If your virus checker says something else then it's wrong! Another potential problem with security software is the performance penalty you can get, if you are running with "corporate level security" of encrypted disk drives, multiple antivirus programs, UAC enabled, registry locked etc, don't be surprised if you get poor performance - in some extreme cases where all disk accesses are checked, our software can be virtually unusable.

We don't expect you to have any problems using our software, however if you do, please contact us via our support page.

Installation Instructions:

Save the downloaded setup.exe file to your computer by clicking on the link above. If you already have a copy of our software on your machine this has to be uninstalled before proceeding.
Run setup.exe by double clicking the icon then following the on-screen instructions.

V8.5 Legacy Software:

V8.5 is still available for supporting legacy products such as the DL1 MK2 and VIDEO4, however this is provided on an "as is" basis and is not actively supported. It is possible to install and run V8.5 and V10 alongside each other.