Call me back | My basket | Checkout | Add to email list

     You are here: Website » Knowledge base

« back to website

VideoOverlayConfiguration / MenuBar

Menu bar


You can use the menu bar to select the following options:

File menu

The File menu contains the following:

New Layout – This clears the design pane of all of the controls, so that you can start a new design

Load Layout – If the design area is empty, this menu item opens a File Open dialog that allows you to load a .VGL file. Controls are then laid on the design area as specified in the VGL file. The preview option in the File Open dialog helps you to select the correct VGL file for loading.

if the design area is not empty, then it displays the Load layout dialog. This dialog consists of following options.

  • Clear current layout, and load the new one:
Clears current layout and loads the new layout.
  • Save the current one, clear current layout and load the new one:
Saves the current layout, then removes it from design window and finally loads the new one.
  • Load the new one on-top of the current layout:
Controls from the new layout are placed on top the current layout. Controls on the current layout may not visible after loading the new one, because they might be covered by the new ones. In such a case simply drag and drop the new controls to another place to see the previous ones.
  • Abort, and do not load the new layout:
This option cancels the load layout operation.
  • Save Layout – This saves the design to a VGL file.
Note: When you save a layout, variable information are not saved along with the layout file. If you want to preserve the variable information, use the File -> Save Variable Information command to save the variable information to a file.
  • Load Factory Layouts - This command opens a folder that contains number of ready to use VGL files. These include an overlay similar to the telemetry data seen on television for Formula 1, and a DASH2 overlay. These will also be available for download on our website.
  • Load HD Factory Layouts - This command opens a folder that contains number of ready to use HD VGL files.
  • Preview Mode – This puts the application into ‘preview mode’. In this mode, the design area will display a "mock-up" screen shot of the video generated by the hardware system. All of the controls and panes except for the Edit toolbar button will be locked. You will not be able to add to or edit your design.
  • Edit Mode – This button will only be enabled in the ‘preview mode’. It allows you to return to the ‘edit mode’. Once in the ‘edit mode’, all panes and controls (except for the Edit toolbar button) will be enabled. Once in ‘edit mode’, you can add or edit controls.
  • Calculate Predictive CPU Load - VIDEO4 unit performs several highly CPU intensive tasks at the same time such as real-time DVD quality Audio & Video encoding, Audio/Video multiplexing and synchronise to RT Serial Data, Etc... Processing of the VGL file is also a real-time task that contributes to the CPU Load.
This function is used to get an estimate of the CPU load of video4 system with current configuration (VGL). Having a too complicated VGL file will make the CPU load goes high which may results video frame misses. You can create comprehensive layouts while keeping the predicted CPU load less than or equal 10% ( the recomended value).
  • Exit – Allows you to exit the application.


View menu

The View menu contains the following items.

  • Options – This opens the Options form.
  • List of Supported video formats
  • Zoom levels – Allows you to resize the design area.

Options form

This form will allow you to configure various settings. The controls found on the form are as follows:

  • Grid size (textbox) – Allows you to specify the number of twips between grid marks. (1 pixel = 15 twips). Valid values are between 20 and 1000.
  • Show grid (checkbox) – if this option is selected, the grid will be displayed in the design area.
  • Snap to grid (checkbox) – by selecting this option, you will ensure that when controls are places or moved within the design area, they will snap to the grid.
  • Background Images for the supported video formats - With this option you can define a custom background images for the design area for the selected video formats.


Add Control menu

The Add Control menu contains the different controls that can be added to the design pane.


Configuration menu

This menu will allow you to edit miscellaneous configuration settings related to the VIDEO4.

The items in the view menu are;

  • Auto Start/Stop Recording – Allows you to add Auto Start/Stop recording conditions to the overlay file.
  • Data Configuration - Allows you to configure the data input (for VIDEO4 WITH internal data option) and configure data output and storage frequencies.
  • Internal battery backup - Configure the amount of time to supply the power for the unit using the internal battery backup, when external power is lost.
  • Audio - Allows you to control the mix of internal and external audio for left and right channels.
  • Gear Display – allows you to set up gear display settings
  • RPM - This option is used to configure the engine RPM.
  • Special Icons - Note: Only one specail icon is currently supported.
Enable to display the "CF" card icon on the video to show whether CF card is present or not.
  • Recording configuration - Allows you to configure the settings related to the recording quality of the VIDEO4 system


About menu

This will display a splash screen, indicating the application name and version. You can hide the splash screen by clicking on it.

Page last modified on June 10, 2016, at 12:47 PM